CLI

info

sh ver

passwords

conf term
username admin privilege 15 secret password123
enable secret 0 <pass>
! for telnet:
line vty 0 4
login
password <pass>
end
wr
copy run start

STARTUP_CONFIG_IGNORED

%SYS-6-STARTUP_CONFIG_IGNORED: System startup configuration is ignored based on the configuration register setting.
sh version
...
Configuration register is 0x141

https://www.cisco.com/c/en/us/support/docs/routers/10000-series-routers/50421-config-register-use.html

enable
dir
conf term
boot system flash bootflash:cat4500-ipbasek9-mz.122-54.SG1.bin
exit
wr
copy run star

config-register 0x102

reload

Console baud rate

It is possible to switch console baud rate after boot. It will be applied after system will bootup and executes startup-config.

configure terminal
line con 0
speed 9600
! note: now you need to reconfigure your terminal client to different baud rate
end
wr
copy run star

LLDP

Link Layer Discovery Protocol

enable
config terminal
lldp run
exit
copy run start

show lldp neighbors

PoE

  • show power inline

Enable SNMP

enable
configure terminal
snmp-server community public ro
snmp-server contact <itadmin@grinn-global.com>
snmp-server location GRINN - Serwerownia
exit
copy run start

reload

Reboots switch:

reload

Find MAC on ports

sh mac address-table vlan 1
sh mac address-table vlan 1 | include 50eb\.f62e
show interface Gi0/40
show controllers

show port counters

show interface counters
 
enable
clear counters

diagnose port

show interface Gi0/17

Using Time Domain Reflectometer

enable
test cable-diagnostics tdr int Gi0/17
show cable-diagnostics tdr int Gi0/17

VTP

Jul 11 05:50:11.999: %DTP-5-DOMAINMISMATCH: Unable to perform trunk negotiation on port Gi1/1 because of VTP domain mismatch.

Disable VTP:

enable
conf term
interface range Gi1/1-48
switchport mode access
switchport nonegotiate
end
wr
copy run star

Set VTP domain

conf term
vtp domain home
vtp mode transparent
vtp password home
end
wr
copy run star

SNMP

enable
switch# configure terminal
switch(config)# snmp-server community public RO
switch(config)# exit
switch# copy running-config startup-config